Convirt CMS + managed server install on Ubuntu 14.04+Xen4.4

Seek and render assistance on all issues related to downloading, deploying and configuring ConVirt 2.0 here.

Convirt CMS + managed server install on Ubuntu 14.04+Xen4.4

Postby hans_wurst on Mon Mar 23, 2015 12:07 am

Hello,

I tried several times to install convirt on a Ubuntu Server 14.04. My hypervisor is Xen also on a Ubuntu Server 14.04.
Unfortunately the installation guide did not help me. I got different errors. The questions in this forum are sometimes similar, but the answers didn't help. At the point of dependencies there are errors to virtualenv and python and xenstore.
Also the appliance does not work for xen4.4 with xl.
Is there any install howto or a later appliance to run convirt with xen on ubuntu?

Thank you for your help.
Last edited by hans_wurst on Fri Mar 27, 2015 1:39 am, edited 1 time in total.
hans_wurst
 
Posts: 5
Joined: Wed Mar 18, 2015 4:36 am

Re: General Installation Problems

Postby jd_jedi on Mon Mar 23, 2015 9:53 am

Ubuntu 14.04 is not yet certified for open source version.
Also, Xen 4.4 is not certified.

If you want we might be able to help you get ConVirt running on 14.04, if you are ok with using older version of Xen. (Xen 4.4 might take bit more time).
jd_jedi
 
Posts: 1788
Joined: Mon Mar 09, 2009 6:22 pm

Re: General Installation Problems

Postby hans_wurst on Tue Mar 24, 2015 12:55 am

I don't want to waste your time, if you think it is nearly impossiple to install convirt OS on Ubuntu 14.04 and Xen 4.4. But if you will try to help me, I would really appreciate to use convirt with 14.04 and 4.4.

So I will post you first error and you can decide if it is worth.

Code: Select all
install common functions sourced.
DISTRO Ubuntu
VER 14.04
CODENAME trusty
KERNEL 3.13.0-46-generic
ARCH x86_64
Info: Sourcing /root/convirt-install/install/cms/scripts/../../../common/scripts/Ubuntu_functions
Info: Sourcing /root/convirt-install/install/cms/scripts/../common/Ubuntu_functions
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-xen-3.3
E: Couldn't find any package by regex 'python-xen-3.3'
E: Unable to locate package libxen3
ERROR: installing CMS Prerequisites.
ERROR: Failed installing prerquesite packages.



I didn't try the virtualenv==1.11.6 entry this time, but last time, I tried this case and used also another version mentioned in this forum with easy-install. Same error. You said, if you don't use xen, this error isn't important. But I am using Xen. Any ideas?

Thank you for your help.
hans_wurst
 
Posts: 5
Joined: Wed Mar 18, 2015 4:36 am

Re: General Installation Problems

Postby jd_jedi on Tue Mar 24, 2015 12:42 pm

Attached is a patch that should get going.

Download the attachment.
copy it in convirt directory

tar -xvf downloaded_tarball_filename

Try following the instructions.
Attachments
u14.04_patch.tar
OSS patch for u14.04
(40 KiB) Downloaded 471 times
jd_jedi
 
Posts: 1788
Joined: Mon Mar 09, 2009 6:22 pm

Re: General Installation Problems

Postby hans_wurst on Wed Mar 25, 2015 8:17 am

Wow, thank you CMS runs with your new files. Managed Server not:

Code: Select all
root@vmhost:~/convirture-tools/install/managed_server/scripts# ./convirt-tool install_dependencies
Info: Sourcing /root/convirture-tools/install/managed_server/scripts/../../../common/scripts/Ubuntu_functions
ERROR:  A different toolstack (xl) have been selected!
Xen server (xend) is not running...
Error detecting virtualization platform.
For Xen, please make sure that you reboot in to a Xen kernel and Xen server is running, while for KVM, the kvm modules are correctly loaded.


I copied yout files to convirt-tools folder:
Code: Select all
cp -R install/ convirture-tools

Any ideas?

At cms I could not include the inno-config. mysql did not start after that. But looks like it works either.

If convirt runs, I will write a little howto, if you would like. Finally you just have to upload you ub14.04 file to your webspace and give me the link.
hans_wurst
 
Posts: 5
Joined: Wed Mar 18, 2015 4:36 am

Re: General Installation Problems

Postby jd_jedi on Wed Mar 25, 2015 11:09 am

A. Update TOOLSTACK to use xm in /etc/defaults/xen

TOOLSTACK=xm

Dont remember, if you have to reboot the machine.. may be a good idea.

B. Create a new convirture-tools tarball from ConVirt code. (as patches applies to them as well.)
cd convirt
tar -czf convirture-tools.tar.gz common install/managed_server
Copy that tar ball on to Xen server and follow the instructions.

Good Luck.
jd_jedi
 
Posts: 1788
Joined: Mon Mar 09, 2009 6:22 pm

Re: General Installation Problems

Postby hans_wurst on Thu Mar 26, 2015 2:09 am

Thank you for your help. We're near the end, I think.
OK, changed toolstack. But have to say xm is since many years deprecated and since 4.5 not used. May be a good idea to use xl in later versions.
Setup on managed Server said it was successful.
Unfortunately now there is an error, when I wanted to add the server in convirt. I get the "[Errno 111] Connection refused" error.
The "has_key" error I solved, but this one, I dont know.

To you're B: Of course, I copied the convirt-tools and the install from your ubuntu patch to the server.

Think, after this error, we're done.
hans_wurst
 
Posts: 5
Joined: Wed Mar 18, 2015 4:36 am

Re: General Installation Problems

Postby jd_jedi on Thu Mar 26, 2015 6:09 am

By default the convirt-tool sets up with the SSL protocol. So while adding node use XML-RPC with SSL option.

Also, check that firewall allows 8006. (shut it down for testing.)

/Jd
jd_jedi
 
Posts: 1788
Joined: Mon Mar 09, 2009 6:22 pm

Re: General Installation Problems

Postby hans_wurst on Fri Mar 27, 2015 12:42 am

OK, installation is done. Thank you veryvery much for your help. Now there are some other errors, but server is in CMS. If you want, I will document my steps and post them.
hans_wurst
 
Posts: 5
Joined: Wed Mar 18, 2015 4:36 am


Return to Installation & Configurations Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron